USCCA Website Issues with iPad 5 Mini

I’m still having that problem with this site, on a brand new iPad mini 5! No one has solved the situation and I was told it was Apples problem. I just figured going to the Apple store and telling them I have a problem getting to my favorite gun site, is going to present more problems than I need. It’s the only site on the web that doesn’t work!
I can’t imagine the look on the liberals face when I tell him my problem! I’ll suffer without it when my membership is up. I have to say I was not very satisfied with the “help” I received, plenty of questions but absolutely no resolution! Personally I don’t think it’s Apple! If it was Apple, why does the site still work on older model iPad and computer?
There are IT people smarter than me and no one has come up with a solution, I need a 14 year old conservative hacker!

1 Like

@TB09, @Scott52 - Please answer the questions we’ve posed. We’re trying to help. I have successfully accessed the site with multiple browsers and multiple Apple devices. It isn’t Apple’s problem to solve. There are many things that can cause the type of error you are seeing, but we need your answers before we can point you in the right direction.

1 Like

OK. What causes these screen shots, when trying to log into this site on apple iPad mini 5th generation. Site not available appears when just doing a normal internet search! I am totally open to some “technical” solutions” and or any steps I should take to to open the web site on the internet!

I’m curious is Apple blocking the site!
Ask away!

@Scott52 - you’re experiencing a different problem on different pages than TB09, but let’s try to help you. should simply redirect to USCCA Account ( If your browser is not being redirected properly,

Also, are you using any anti-malware or anti-virus software? The “Site information/Site Security” message seems to indicate there is something on your iPad that doesn’t like the page.

Which browser are you using? Have you tried other browsers?

Otherwise, have you tried going directly to USCCA Account ( seems to be an invalid page. From where are you attempting to get to that page?

True! But A problem just the same that I have been trying to resolve for over a week now. So we will go slow.

First, can’t get to the portal. When using Safari. When using Safari just typing in USCCA as a search, all the listings come up. I click on the one with the Yellow Logo
And the following page opens up.

When using the old iPad 3 the following page opens up and I login as “normal”

As you can see I attempted that as I am writing.

When I tap/press/click on “Log in” The page does not respond in Safari, however
When using Chrome, this page shows up when clicking “log in”

Now let’s move on to the Anti Virus software, YES. Norton w/VPN When I disabled the anti virus and VPN NO CHANGE!
Yes I have tried going to USCCA ACCOUNT directly, have tried each possible configuration including. /login. /account used dot net instead of .com
Have also typed in login and all other configurations while on the phone with USCCA.

Which version of the iPad operating system are you running? When was the last time you restarted the iPad from power-down?

The new IPad is the IPad mini 4 (5th generation, latest model) per the description on my receipt and in the description of the iPad in the iPad
Version 14.4.2
When I purchased it was 14.4.1 week and a half ago. I have done a hard shutdown and a soft restart maybe twice. Once when I couldn’t log on when the first transfer from old iPad was complete And then again when I downloaded Chrome and was unsuccessful reaching my account.

As per the USCCA rep on the phone she asked that I disable the APP and try again, then download the APP and try again, don’t know what the APP had to do with web page but obliged! Unsuccessful

BTW upon doing the transfer from one iPad to another I noticed my shortcut or favorited USCCA LOGO IS YELLOW on old iPad but still BLUE (old logo) on new pad!

Which app were you asked to “disable” and how did you do that?

the USCCA APP that contains News Feed/reciprocity map/CCM/Account/more.
I was asked to delete it by holding down n the APP till it shook and chose to DELETE APP without keeping any of the data.
Then was asked to re install and try again, unsuccessful, APP works but not the website!
Appreciate your assistance!


I can’t help but think that there’s a problem with both Safari and Chrome. Have you ever used Firefox or Edge?

I have not used either of those. There is one thing I have not tried and that is deleting Safari and reinstalling it, didn’t know if that is a good idea?
Appreciate what you’ve done anyway!

Took a chance, can’t delete Safari!
Just attempted Firefox no luck!

What was the result? The same as Safari or the same as Chrome?

Similar, can’t get past login.

My son in law is a computer geek, let’s just say his home computer is water cooled, and will be here for Easter weekend, if he wants to eat…

It just occurred to me that you are referencing a 5th gen iPad. Is that accurate? The most recent generation is 8th gen.

iPad MINI 4 (5th generation)

OK, thanks. It’s current, then.

I’ll be honest. Without getting my hands on it, I’m stumped.

Apple - 7.9-Inch iPad mini (5th Generation) with Wi-Fi - 64GB - Space Gray.

As I have been for the past week and a half. Back in the late eighties I networked computers for art galleries and frame shops. Things changed too rapidly to keep up! The new generation took over and I was done!
I’m lucky I know how to charge my phone! When my grandkids got us our first smart phones, they taught us how to hack the White House, but never showed us how to make a call, because we couldn’t find the number pad to dial, and answering the phone, well no one could reach us for months! We were MIA until they did a welfare check on us!
Hey thanks for your time and effort!

1 Like

You have probably already tried this but I did not see it mentioned.

Open up the settings app on your new iPad.
Scroll down to the safari app and open
Scroll down to clear history and website data and select clear the history.

You would then need to search for or enter the USCCA site without using any pre saved bookmarks or favorites links.

1 Like

Done, just tried that, got to the grey page as referenced above, I can click on Join, Train, Learn… but in the upper right to login, nothing happens. When I go to community it gives me a white page as referenced above.
I entered the site as

The strange thing is every other website like USPSA etc… I can log into
Even a clean web search, yields nothing. As a matter of fact. This may mean nothing, however, when doing just a Safari search for USCCA the letters in the search answers are Purple, while all others for USCCA are in blue.
When using Safari and using the Google search engine still get grey page and unable to log in.
Just tried again I got in!

Topic split off to its own thread and shared wit the team at Delta Defense service provider for the USCCA.

Hopefully the tech gurus can jump in here and get it squared away.