- Trouble with the website


I know this is minor and maybe even petty…but no matter what device I use or what browser, I can never get the appleseed project to come up. I’ve tried going through the search engines, I’ve tried other round about ways. It seems like it’s been like this for month. The website site always times out with the message “this site can’t be reached.”

Is anyone else having this problem? Am I cursed? Is there some secret I don’t know about? What did I do wrong :sob:?

I got to the site, and the forums, just fine. Even using a VPN. When you say “not come up”, describe what you mean? Are you using HTTP or HTTPS? Have you cleared your browser cache and cookies? What is the exact address you are using?

It’s working fine for me. I know, that’s not much help for you.

Who is your Internet provider?

13 posts were split to a new topic: USCCA Website Issues with iPad 5 Mini


Copied this from another thread and the link works for me.

Actually I’ve been trying on an iPhone and Apple Macbook. That is the website I’ve been using (, thank you for confirming

The irony of trying to reach “” on Apple products… :laughing: :apple:

I’ll try it on a PC and see what happens. Thanks, y’all!!!

1 Like

I don’t want to add to the confusion but I’m confused. This entry is on my iPhone using Safari it seems to work fine. Whatever happened to the Appleseed thing?

I scrolled back through the comments and was able to use the link to Appleseed on safari.

Thanks everyone for the advice (on the appleseed website).

In summary, I have tried to access the Appleseed Project (AP) website on:

  • an iphone by Safari, the Brave Browser, and the DuckDuckGo Browser.
  • a MacBook with the Safari broswer and Brave browser.

On both devices and all browsers, the website times out :(. So I am going to try and see if I can get the website on a PC. Will follow up if there is any luck. I have heard great things about the A.P.

It looks like a new topic split off for USCCA website issues. Good luck and thanks again! :crossed_fingers: :pray:

1 Like

@TB09 - it sounds like the problem you are seeing is more network-related than device-related. Are you attempting to access the site from your home network? Cell network? Another wifi network?

This reminds me that I spent an enjoyable hour or two with a very pleasant USCCA rep when I had log on issues. We were both pulling our hair out and she got IT involved to no avail. I tried reconnecting to my modem from the desktop and nothing changed, Out of desperation I restarted the modem (comcast) and suddenly it worked. :exploding_head:

Sometimes, that’s what it takes.

We had a brief power outage on Sunday evening here. All of our wifi components are on an uninterruptible power supply. The next morning, my Windows-based work laptop wouldn’t connect and was just acting very strange. I rebooted the laptop and all was well. It was very odd, since neither our modem, nor our wifi router,nor the laptop ever lost power.

1 Like