Bug in Protector Academy Lesson 1 Intro, safety, & handgun features

Lesson 1, Introduction, safety, and handgun features. sub-three: Handgun features, “Actions” video segment.
FAILS (discovered afterward takes a significant amount of time…) to load, allows the viewer to scroll below and read content, and depress the “continue” button.
Until the video segment is played out, FAILS to unlock the system to carry forward and allow the viewer to continue the module.

This wouldn’t be so bad, but if the viewer does not view this video, they have to completely re-play the content to this point, not moving forward.

Reproducible. This occurs in Windows 10 Microsoft Edge, Version 86.0.622.51 (Official Build) (64-bit), and Version 86.0.4240.111 (Official Build) (64-bit) Google Chrome.

*** I discovered, after leaving Chrome windows open in the background and playing content out to the same location in Edge, upon returning to Chrome, a system dialog box is asking if “I’m still here.” Selecting I’m still here then allows me to start and play the “Actions” video segment.

It seems either this file is much larger than others that have played before. Therefore, it takes significant time to be served from the origination file server, or there is some ‘bottleneck’ in the path between the source server(s) and my destination here in Atlanta.

I can assure you I have a fast, wide, gigabit pipe from Comcast, and this experience is unique in my recent experience. I would estimate at least a five or more minute wait for the load as I experienced the MS Edge session pick up and start playing after discovering the Chrome session actually had the content qued and playing.

I made mention in chat last Friday about my experience. It was only today I discovered the extended wait time for the video clip to download and become available. I am documenting here to provide a location for other feedback as I and the userbase may come upon issues or points of discussion.

1 Like

??? Am I missing a link or something?

@John512 When I go to my Account page when I’m signed in, I have this graphic with a live link to access the training product “Protector Academy”

It may be a service offered with the different levels of subscription you have with USCCA.
By the by if you haven’t subscribed take a look here: USCCA membership information

I had the same issue. And if I missed the pop-up then I had to go back to the account page to be logged back in. I could then pick up where I left off. What should happen is that when a video is playing you continue to be seen as logged in and active.

Thanks guys! I’ll let them know! (IF you find any more bugs, please list them here and tag me. I’ll let our tech team know.)

Thanks again for the assist!

1 Like

@Fish That makes sense. Though aside from the specific instance above, I’d never needed to leave the computer, for that long, for something going down in the house!

One thing I thought was a bit of a pain was the experience if I did leave before designed ‘bookmarks’ my progress to that point would be dismissed and I had to start from the top of the first lesson’s module. Overall it wasn’t a huge investment of time but by the fourth or fifth time I was thinking “I’ll come back in a couple of months or so.”

( In retrospect I can see the developers conundrum ‘Do I have to flag for every sentence or can I just note the chapter progress?’)

@Dawn As always milady, it is an honor to serve. Thank you for your service!

1 Like

Movie 5.2: I’ve tried a couple of times but the movie and the commentary are both playing at the same time, making it quite difficult to understand either one.

Edit: Clarified what was happening.
The movie starts when you get to the screen, instead of waiting until you click on it. Chrome 86.0.4240.111.

Emergency Preparedness Fundamentals: Preparing to Survive

Watched the first (~5.5min) and second (~12.5min) videos. When I clicked on the third to view it all I got was a spinning loading wheel. After a minute or my only choice was to close the training by clicking on the X.


Lo and behold, I now have to go through the first and second again. The videos cannot be skipped, nor can they sped up or just fast-forwarded. So, on the second time through I get to the video “Seeing Beyond the Ordinary” and the same thing happens. :disappointed:

I’m going to just hold on this one until it gets fixed, then I’ll go through the rest and see how it goes. :persevere:


I gave this one a shot again this morning and, after reloading the page multiple times, it finally played all the way through. I’m continuing on and will post any issues to this thread, should I find any.

1 Like

A lot of the time I select the next lesson and the video never comes up or I get an error alert 400. I even sometimes just get a blank page. I have tried logging out and logging back in, rebooting the unit, and clearing out the history. Even updating the OS on the iPad.